import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<machinenr>[^\\|]*?)\\|\n"
+ "(?P<controldone>[^\\|]*?)\\|\n"
+ "(?P<nrofitems>[^\\|]*?)\\|\n"
+ "(?P<items>[^\\|]*?)\\|$";
final String string = "446408|0|1|111|446408|0|3|99884|111|73732|446408|0|0||";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}