// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)^(?P<machinenr>[^\|]*?)\|
(?P<controldone>[^\|]*?)\|
(?P<nrofitems>[^\|]*?)\|
(?P<items>[^\|]*?)\|$").unwrap();
let string = "446408|0|1|111|446408|0|3|99884|111|73732|446408|0|0||";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}