$re = '/(\bsrc="[^ =]+=)"([^ "]+")"/';
$str = '<img src="imagename=g1" alt = "">
<img src="imagename="g1"" alt = "">';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;