import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "YMS\\-15|MSM\\-10|YMS\\-14|MAN\\-07|MSN\\-02|MSM\\-07S|MA\\-05|MSM\\-07|MSM\\-04F|MSM\\-03|MS\\-X16|MAN\\-03|MS\\-X10|MS\\-14A|MS\\-R09|MS\\-06F|MS\\-14|MS\\-11|MS\\-09R|MS\\-09|MS\\-07B|MS\\-07|MS\\-06S|MS\\-06J|MS\\-06|MSN\\-X2|MS\\-05B|MAX\\-03|MS\\-14S|MAN\\-X3|MAN\\-08|MA\\-08|MA\\-05H|MAN\\-X8|MA\\-04X|MSM\\-04|MAM\\-07|YMS\\-07B";
final String string = "MAM-07\n\n"
+ "YMS-07B\n"
+ "YMS-07 -- 無効なモデル名だが部分マッチしている";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}