$re = '/(?si)\s*<img\b(?>(?!src=).)*?\/>\s*/';
$str = '<html>
<img src="someurl" alt="something" />
<img alt="something" />
<img alt="somethingelse"
att=\'val\' />
<html />';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;