# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?si)\s*<img\b(?>(?!src=).)*?\/>\s*"
test_str = ("<html>\n"
" <img src=\"someurl\" alt=\"something\" />\n"
" <img alt=\"something\" />\n"
" <img alt=\"somethingelse\"\n"
" att='val' />\n"
"<html />")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.