const regex = /([a-zA-Z_]\w*?)=(\d+|"[^"]*")( |$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z_]\\w*?)=(\\d+|"[^"]*")( |$)', 'gm')
const str = `a=123 b="ABC" c="Olá Mundo!"
var1=123 var2="ABC" hello_world="Olá Mundo!"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}