package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<\/?a\b[^>]*?\/?>`)
var str = `Leave <anyother> in. This is a string that contains <a id=something>multiple</a> instan<a href=one thing/>ces of the <a href=another thing>codes</a> that I want to strip out.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}