# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[a-z][0-9a-z-.+]*:\/\/)?((?:(?:[a-z\u00a1-\uffff0-9_]+-?)*[a-z\u00a1-\uffff0-9_]+)(?:\.(?:[a-z\u00a1-\uffff0-9_]+-?)*[a-z\u00a1-\uffff0-9_]+)*(?:\.(?:[a-z0-9\u00a1-\uffff]{2,})))(?::\d{2,5})?(?:\/.*)?(?:\?.*)?(?:\#.*)?$"
test_str = ("socks://www.example.com\n"
"10.1.1.1\n"
"10.1.1.2/4\n"
"10.1.1.3/0\n"
"10.1.1.0/8\n"
"10.1.1.5/32\n"
"10.1.1.6/35\n"
"10.1.1.7/36000\n"
"10.1.1.8/abcd\n"
"10.1.1.9-10.1.1.10\n"
"user:pass@zxuz.com\n"
"user@proxy.brew.opendnstest.com/customBlockUserInfo\n"
"user:@proxy.brew1.opendnstest.com/customBlockUserInfo\n"
"user:password@proxy.brew2.opendnstest.com/customBlockUserInfo\n"
"ftp://cnn.example.com&story=breaking_news@foobar.com/top_story.htm\n"
"foo.com:8080/bar/baz\n"
"asdfasdf.com/foo/b%20ar\n"
"https://example.com/archive/*/http://somesite.com\n"
"foobar.com/boo\n"
"http://foobla.com/foo")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.