package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)PT(.*?$)`)
var str = `abced @ 1.20689\nLS @ 1.22000\nPT1 @ 1.1900\nPT2 @ 1.1800
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}