package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\(?([0-9]{3})\)?[-. ]?([0-9]{3})[-. ]?([0-9]{4})$`)
var str = `0123456789
012.345.6789
012-345-6789
+1-012-345-6789
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}