re = /^\(?([0-9]{3})\)?[-. ]?([0-9]{3})[-. ]?([0-9]{4})$/
str = '0123456789
012.345.6789
012-345-6789
+1-012-345-6789
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end