// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx) ^ # start of line
{\w+} # any word character wrapped by curly brackets
\s\S+ # space followed by one or more Not-spaces
\s\S+ # space followed by one or more Not-spaces
\s-\s # space-dash-space
( # --First match group:
New\s\w+ # ‘New’ followed by space and one or more word chars
\s-\s # space-dash-space
New\s\w+ # ‘New’ followed by space and one or more word chars
) # --END First match group
\s* # one-or-more spaces (you can remove this, I think)
$ # end of line
").unwrap();
let string = "{BANANAS} 2015/02/03 16:10 - Old look - Old Design
{BALOONS} 2015/02/03 16:23 - New look - New Design
{ORANGES} 2015/02/03 16:30 - Old look - Old Design
{BALOONS} 2015/02/03 16:50 - New look - New Design
{CARS} 2015/02/03 16:55 - New link - New Creation";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}