const regex = new RegExp('(^ *\\S+ *$)|(^ *(\\S+ ){1,3}\\S+ *$)|(^ *(\\S+ ){5,}\\S+ *$)|(^ +(\\S+ ){4}\\S+ +$)', 'mg')
const str = `fsfdaf
ax x dx x xa
x x
x
x x x x
x x x
x x x x x x
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}