re = /^(BEJ|KIM)-([0-9]{8})\/([0-9]{3})\/([0-9]{4})$/
str = 'BEJ-12345678/001/2014'
# Print the match result
str.match(re) do |match|
puts match.to_s
end