#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:\+?(?:(?:\d){1,3}[ .-]?))?\(?(?:\d{3})\)?[ .-]?\d{3}[ .-]?\d{4}$"
Local $sString = "+1 951-543.1630" & @CRLF & _
"9515431630" & @CRLF & _
"951.543.1630" & @CRLF & _
"951-543-1630" & @CRLF & _
"(951)-543-1630" & @CRLF & _
"951 543 1630" & @CRLF & _
"4000220220448316" & @CRLF & _
"300 951 543 1630" & @CRLF & _
"12 852 456 1562" & @CRLF & _
"" & @CRLF & _
"1562215622"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")