using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\+?(?:(?:\d){1,3}[ .-]?))?\(?(?:\d{3})\)?[ .-]?\d{3}[ .-]?\d{4}$";
string input = @"+1 951-543.1630
9515431630
951.543.1630
951-543-1630
(951)-543-1630
951 543 1630
4000220220448316
300 951 543 1630
12 852 456 1562
1562215622";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}