# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:\+?(?:(?:\d){1,3}[ .-]?))?\(?(?:\d{3})\)?[ .-]?\d{3}[ .-]?\d{4}$"
test_str = ("+1 951-543.1630\n"
"9515431630\n"
"951.543.1630\n"
"951-543-1630\n"
"(951)-543-1630\n"
"951 543 1630\n"
"4000220220448316\n"
"300 951 543 1630\n"
"12 852 456 1562\n\n"
"1562215622")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.