package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+):([^;]*)`)
var str = `key_1: some text, maybe a comma, ending in a semicolon; key_2: text with no ending semicolon`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}