Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^[0-9]{1,2}\.[0-9]{1,2}\.[0-9]{1,2}([0-9]{5,7}[X|B]([0-9]{1,2}))?$
/
gm
Input 1
1
New
1.1.1111111X1