import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^hsla?\\(\\s*(?<h>[-+]?\\d{1,3}(?:\\.\\d+)?)(deg|grad|rad|turn)?\\s*(?:,\\s*|\\s+)\\s*(?<s>[-+]?\\d{1,3}(?:\\.\\d+)?)%\\s*(?:,\\s*|\\s+)\\s*(?<l>[-+]?\\d{1,3}(?:\\.\\d+)?)%\\s*(?:,\\s*|\\s+)?(?:\\s*\\/?\\s*(?<alpha>[-+]?[\\d.]+%?)\\s*)?\\)$";
final String string = "\n"
+ "hsl(.9, .99%, .999%, .9999)\n"
+ "hsl(0240, 0100%, 0050%, 01) \n"
+ "hsl(2400, 1000%, 1000%, 10)\n"
+ "hsl(-2400.01deg, -1000.5%, -1000.05%, -100)\n"
+ "hsl(2.40e+2, 1.00e+2%, 5.00e+1%, 1E-3)\n\n"
+ "hsl(-240, -100%, -50%, -0.1)\n"
+ "hsl(+240, +100%, +50%, +0.1)\n"
+ "HSL(240Deg, 100%, 50%)\n"
+ "hsl(240, 100%, 50%, 10%)\n"
+ "hsl(150deg 30% 60%)\n"
+ "hsl(0.3turn 60% 45% .7)\n"
+ "hsl(0.3grad 60% 45% / .7)\n"
+ "hsl(0.3rad 60% 45% / .7)\n"
+ "hsl(12 60% 45% / .7)\n"
+ "hsl(120, 100%, 50%)\n"
+ "hsl(0, 0%, 0%)\n"
+ "hsl(60, 50%, 75%)\n"
+ "hsl(270, 80%, 60%)\n"
+ "hsl(200, 20%, 40%)\n"
+ "hsl(340, 90%, 80%)\n"
+ "hsla(120, 100%, 50%, 0.5)\n"
+ "hsla(0, 0%, 0%, 0.2)\n"
+ "hsla(60, 50%, 75%, 0.8)\n"
+ "hsla(270, 80%, 60%, 0.4)\n"
+ "hsla(200, 20%, 40%, 0.6)\n"
+ "hsla(340, 90%, 80%, 0.1)\n"
+ "hsl(120 100% 50%)\n"
+ "hsl(0 0% 0%)\n"
+ "hsl(60 50% 75%)\n"
+ "hsl(270 80% 60%)\n"
+ "hsl(200 20% 40%)\n"
+ "hsl(340 90% 80%)\n"
+ "hsla(120 100% 50% / 0.5)\n"
+ "hsla(0 0% 0% / 0.2)\n"
+ "hsla(60 50% 75% / 0.8)\n"
+ "hsla(270 80% 60% / 0.4)\n"
+ "hsla(200 20% 40% / 0.6)\n"
+ "hsla(340 90% 80% / 0.1)\n"
+ "hsl(240, 100%, 50%)\n"
+ "hsl(240, 100%, 50%, 0.1)\n\n"
+ "hsl(240,100%,50%,0.1)\n"
+ "hsl(180deg, 100%, 50%, 0.1)\n"
+ "hsl(3.14rad, 100%, 50%, 0.1)\n"
+ "hsl(200grad, 100%, 50%, 0.1)\n"
+ "hsl(0.5turn, 100%, 50%, 0.1)\n\n"
+ "hsl(240.5, 99.99%, 49.999%, 0.9999)\n\n\n"
+ "hsl(240.0, 100.00%, 50.000%, 1.0000)\n\n"
+ "hsl(240 100% 50%)\n"
+ "hsl(240 100% 50% / 0.1)\n"
+ "hsla(240, 100%, 50%)\n"
+ "hsla(240, 100%, 50%, 0.1)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}