import re
regex = re.compile(r"^<iframe.+?src=\"https?:\/\/www\.youtube\.com\/embed\/([a-zA-Z0-9_-]{11})\"[^>]+?><\/iframe>$")
test_str = "<iframe width=\"560\" height=\"315\" src=\"https://www.youtube.com/embed/wRqjJ7SENDI\" frameborder=\"0\" allowfullscreen></iframe>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")