use strict;
my $str = '9999
5446
1
2
12
99
100
0
1234
9999
10000
';
my $regex = qr/^(?:[1-9][0-9]{3}|[1-9][0-9]{2}|[1-9][0-9]|[1-9])$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";