const regex = /(?:(\.\.\/)|)(img|imgs|image|images)(.*[\\\/])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(\\.\\.\\\/)|)(img|imgs|image|images)(.*[\\\\\\\/])', 'g')
const str = `"../img/hero/layer4.png
"../images/bg-top.jpg
'img/logo.jpg
'img/btn/banner-submit.jpg
"img/btn/animated-thank-you-banner.gif
<img src="img/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}