#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:(?!^\s|\s$)[a-z0-9\s]){1,20}$"
Local $sString = "12345678901234567890" & @CRLF & _
"12345678901234567890foo" & @CRLF & _
" 12345" & @CRLF & _
"12345 12345" & @CRLF & _
"12345 " & @CRLF & _
"a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")