$re = '/^(?:(?!^\s|\s$)[a-z0-9\s]){1,20}$/mi';
$str = '12345678901234567890
12345678901234567890foo
12345
12345 12345
12345
a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);