using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+)";
string input = @"[""durov@telegram.org"",""active"",""available"",""2015-02-12 14:14:54"",""00.000.00.000"","",""0.0.0.0"",""1111114"",""2014-05-12 18:00:00"","","","","","",""0.0.0.0"","","","","",""Pavel"",""Durov"",""]
[""admin@sd.com"",""active"",""available"",""2015-02-12 14:14:54"",""00.000.00.000"","",""0.0.0.0"",""1111114"",""2014-05-12 18:00:00"","","","","","",""0.0.0.0"","","","","",""Thank"",""You"",""]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}