use strict;
my $str = '["durov@telegram.org","active","available","2015-02-12 14:14:54","00.000.00.000","","0.0.0.0","1111114","2014-05-12 18:00:00","","","","","","0.0.0.0","","","","","Pavel","Durov",""]
["admin@sd.com","active","available","2015-02-12 14:14:54","00.000.00.000","","0.0.0.0","1111114","2014-05-12 18:00:00","","","","","","0.0.0.0","","","","","Thank","You",""]';
my $regex = qr/([a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}