# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+)"
test_str = ("[\"durov@telegram.org\",\"active\",\"available\",\"2015-02-12 14:14:54\",\"00.000.00.000\",\"\",\"0.0.0.0\",\"1111114\",\"2014-05-12 18:00:00\",\"\",\"\",\"\",\"\",\"\",\"0.0.0.0\",\"\",\"\",\"\",\"\",\"Pavel\",\"Durov\",\"\"]\n"
"[\"admin@sd.com\",\"active\",\"available\",\"2015-02-12 14:14:54\",\"00.000.00.000\",\"\",\"0.0.0.0\",\"1111114\",\"2014-05-12 18:00:00\",\"\",\"\",\"\",\"\",\"\",\"0.0.0.0\",\"\",\"\",\"\",\"\",\"Thank\",\"You\",\"\"]")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.