re = /([a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+)/
str = '["durov@telegram.org","active","available","2015-02-12 14:14:54","00.000.00.000","","0.0.0.0","1111114","2014-05-12 18:00:00","","","","","","0.0.0.0","","","","","Pavel","Durov",""]
["admin@sd.com","active","available","2015-02-12 14:14:54","00.000.00.000","","0.0.0.0","1111114","2014-05-12 18:00:00","","","","","","0.0.0.0","","","","","Thank","You",""]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end