# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^|]+$)/$1/gm;t' <<< "Sample text for testing:
abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ
0123456789 _+-.,!@#$%^&*();\/|<>\"'
12345 -98.7 3.141 .6180 \9,000 +42
555.123.4567 +1-(800)-555-2468
foo@demo.net bar.ba@test.co.uk
www.demo.com http://foo.co\.uk/
http://regexr.com/foo.html?q=bar
https://mediatemple.net||Test "