re = /([^|]+$)/m
str = 'Sample text for testing:
abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ
0123456789 _+-.,!@#$%^&*();\\/|<>"\'
12345 -98.7 3.141 .6180 \\9,000 +42
555.123.4567 +1-(800)-555-2468
foo@demo.net bar.ba@test.co.uk
www.demo.com http://foo.co\\.uk/
http://regexr.com/foo.html?q=bar
https://mediatemple.net||Test '
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result