re = /<html(\s+([a-z\-]+)=('|")([^"'>]*)('|"))*>/mi
str = '<html class="my-class" lang="en">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end