# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\b\d{1,2}\/) +(\d{1,2})(?=\/\d{4}\b)/\1\2/gmiu;t' <<< "11/ 1/2015
12/ 12/2015
1/ 1/2015"