use strict;
my $str = '11/ 1/2015
12/ 12/2015
1/ 1/2015';
my $regex = qr~(\b\d{1,2}/) +(\d{1,2})(?=/\d{4}\b)~miup;
my $subst = '\\1\\2';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";