using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(season|s)\s*(\d+)(episode|e|x)\s*(\d+)";
string input = @"Hello seinfeld season 01episode 22 foo bar
s 01e 02
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}