#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a.*<\/a>"
Local $sString = "<dl>" & @CRLF & _
                "<dd>[1] <a href="/wiki/Geb%C3%A4ude" title="Gebäude">Gebäude</a>, <a href="/wiki/R%C3%A4umlichkeit" title="Räumlichkeit">Räumlichkeit</a>, <a href="/wiki/Unterkunft" title="Unterkunft">Unterkunft</a>" & @CRLF & _
                "</dd>" & @CRLF & _
                "<dd>[2] die <a href="/wiki/Gemeinschaft" title="Gemeinschaft">Gemeinschaft</a> der <a href="/wiki/Mensch" title="Mensch">Menschen</a>, die unter einem Dach zusammen leben, wohnen oder arbeiten</dd>" & @CRLF & _
                "<dd>[3] der <a href="/wiki/Unterhaltung" title="Unterhaltung">Unterhaltung</a> dienendes Gebäude</dd>" & @CRLF & _
                "<dd>[4] <i><a href="/wiki/Astrologie" title="Astrologie">Astrologie</a>:</i> <a href="/wiki/Tierkreiszeichen" title="Tierkreiszeichen">Tierkreiszeichen</a>" & @CRLF & _
                "</dd>" & @CRLF & _
                "<dd>[5] <a href="/w/index.php?title=Herrscherhaus&action=edit&redlink=1" class="new" title="Herrscherhaus (Seite nicht vorhanden)">Herrscherhaus</a>" & @CRLF & _
                "</dd>" & @CRLF & _
                "<dd>[6] <a href="/wiki/Firma" title="Firma">Firma</a>, <a href="/wiki/Unternehmen" title="Unternehmen">Unternehmen</a>" & @CRLF & _
                "</dd>" & @CRLF & _
                "<dd>[7] <a href="/wiki/scherzhaft" title="scherzhaft"><i>scherzhaft</i></a> <a href="/wiki/Freund" title="Freund">Freund</a>" & @CRLF & _
                "</dd>" & @CRLF & _
                "<dd>[8] <i><a href="/wiki/umgangssprachlich" title="umgangssprachlich">umgangssprachlich</a>:</i> Gehäuse der <a href="/wiki/Schnecke" title="Schnecke">Schnecke</a>" & @CRLF & _
                "</dd>" & @CRLF & _
                "<dd>[9] Gasthaus oder <a href="/wiki/Gastst%C3%A4tte" title="Gaststätte">Gaststätte</a>" & @CRLF & _
                "</dd>" & @CRLF & _
                "</dl>" & @CRLF & _
                ""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")