#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^\(?\+?[\(\)\- 0-9]{8,20}$"
Local $sString = "(+56)=1 23 467 890"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)