using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\(?\+?[\(\)\- 0-9]{8,20}$";
string substitution = @"";
string input = @"(+56)=1 23 467 890";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}