const regex = /(?<="product": ")(.*?)(?=")/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<="product": ")(.*?)(?=")', '')
const str = `{"product": "product1"},{"product": "product2"},{"product": "product3"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}