re = /(?<="product": ")(.*?)(?=")/
str = '{"product": "product1"},{"product": "product2"},{"product": "product3"}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end