$re = '/Size:\s+([A-Z0-9-]+),/m';
$str = 'Size: XS-S-M-L-XL-2XL,
Size: XS-S-M,';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;