# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"O\s+(?P<O>\d+\.\d+\.\d+\.\d+.*(?:[\r\n]+[^\S\r\n]+.*)?)"
test_str = ("Gateway of last resort is not set\n\n"
" 10.0.1.0/8 is variably subnetted, 4 subnets, 2 masks\n"
"C 10.1.0.0/24 is directly connected, Ethernet1/0\n"
"L 10.1.0.1/32 is directly connected, Ethernet0/0\n"
"C 10.2.0.0/24 is directly connected, Ethernet0/1\n"
"L 19.18.2.1/32 is directly connected, Serial2/1\n"
"O 19.18.3.0/20 [110/128] via 19.18.2.2, 00:00:50, Serial1/1\n"
" [110/128] via 19.18.1.2, 00:00:50, Serial1/0\n\n"
"O 12.18.3.1/20 [110/128] via 19.18.2.2, 00:00:50, Serial1/1\n"
" [110/128] via 19.18.1.2, 00:00:50, Serial1/0\n\n"
"O 12.18.1.0/20 [110/128] via 19.18.2.2, 00:00:50, Serial0/1\n"
" [110/128] via 19.18.1.2, 00:00:50, Serial0/0")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.