package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\d+\b`)
var str = `azeaze4 T4 45-azej565 5T 555T 44444`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}