$re = '/\b\d+\b/';
$str = 'azeaze4 T4 45-azej565 5T 555T 44444';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);