$re = '/(0[1-9]|5[0-2]|[0-4][0-9])[0-9]{3}/i';
$str = '13548
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);