#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i){/(^\[|b)/g}"
Local $sString = "Digital imaging and semiconductor image sensor technology facilitated the development and rise of social media.[11] Advances in metal-oxide-semiconductor (MOS) semiconductor device fabrication, reaching smaller micron and then sub-micron levels during the 1980s–1990s, led to the development of the NMOS (n-type MOS) active-pixel sensor (APS) at Olympus in 1985,[12][13] and then the complementary MOS (CMOS) active-pixel sensor (CMOS sensor) at NASA's Jet Propulsion Laboratory (JPL) in 1993.[12][14] CMOS sensors enabled the mass proliferation of digital cameras and camera phones, which bolstered the rise of social media.[11]"
Local $sSubst = "dkjd"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)