const regex = /^([1-9]|0[1-9]|1[012])([-\/.])([1-9]|0[1-9]|[12][0-9]|3[01])\2(\d{4})$|^(\d{4})([-\/.])([1-9]|0[1-9]|[12][0-9]|3[01])\6([1-9]|0[1-9]|[12][0-9]|3[01])$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([1-9]|0[1-9]|1[012])([-\\\/.])([1-9]|0[1-9]|[12][0-9]|3[01])\\2(\\d{4})$|^(\\d{4})([-\\\/.])([1-9]|0[1-9]|[12][0-9]|3[01])\\6([1-9]|0[1-9]|[12][0-9]|3[01])$', '')
const str = `14/11/2015`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}