re = /^(((-?\d*(,\d+)?\*?)|\d+\/\d+)?(x(\^-?\d+)?)?)((\+|-)(((-?\d*(,\d+)?\*?)|\d+\/\d+)?(x(\^-?\d+)?)?))*$/
str = 'x^11-3x^9+12x^7+57/23x^6-6x^5+x^4-11*x^3+x^2-x-33
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end