re = /((([A-Z][a-z]*(\s))([a-z]*(\s))*[a-z]*[.])(\s)*)*(?!([A-z0-9]*(\s)))/
str = 'Theqwererwerwewe qwe ertret asdf. The wer. The awerwe. The we. The wewe. The awe. '
# Print the match result
str.match(re) do |match|
puts match.to_s
end